Welcome to the Rx7 Forum and Owners Club.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

<<<<<< Register to remove these ads >>>>>>


Go Back   Rx7 Forum and Owners Club > Specific RX-7 Models > 2nd Generation

2nd Generation 1986-1992 Discussion


Reply
 
Thread Tools Display Modes
Old 10-23-2016, 06:37 PM   #1
Tarantula
Junior Member
 
Join Date: Oct 2016
Posts: 1
Default 1988 rx7 o2 sensor wire location. Please help!
Hello everyone, I purchased a 1988 RX7 Non-Turbo and it failed smog because O2 Sensor wire has been cutoff on wiring harness connector side. I cannot find the wire in the harness anywhere. I have looked at both sides of the engine harness and under the car but no luck.

I believe I have the correct wiring diagrams and it says the wire should be Green/Yellow Stripe but there is nothing loose, cut, or any connectors unplugged that have that color wire. The only wire I can find unconnected is on top of the engine by Throttle body and it is Green/Black Stripe.

Please help ASAP.

Thanks, Chuck
Tarantula is offline   Reply With Quote
Old 04-11-2017, 12:51 PM   #2
rotorlife
Junior Member
 
Join Date: Apr 2017
Age: 61
Posts: 10
Default
I was touched by the same problem, help with advice


__________________
192.168.1.1

Last edited by rotorlife; 06-01-2017 at 07:20 PM.
rotorlife is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump