Welcome to the Rx7 Forum and Owners Club.
If this is your first visit, be sure to check out the FAQ by clicking the link above. You may have to register before you can post: click the register link above to proceed. To start viewing messages, select the forum that you want to visit from the selection below.

<<<<<< Register to remove these ads >>>>>>


Go Back   Rx7 Forum and Owners Club > General RX-7 Area > TECH Support

TECH Support Technical Support for your RX7, Open 24/7/365. Post your problems and see if someone can help!


Reply
 
Thread Tools Display Modes
Old 05-09-2013, 06:25 AM   #1
Redconvertible
Junior Member
 
Join Date: May 2013
Age: 35
Posts: 3
Default Need help
In need of help or ideas. I have an 89 RX7 convertible that I attempted to replace the factory radio in. Upon removing the radio from the dash and installing the aftermarket system I noticed the aftermarket system not functioning properly. I put the factory radio back in but now the car won't start. The battery is good and it starts to turn over but won't start. I thought it was flooded but have waited hours with no luck. My factory alarm won't set but if I unlock the car from the drivers side the security light flashes. Also when I remove the key from the ignition the security light flashes. Any help would be appreciated.
Redconvertible is offline   Reply With Quote
Old 05-10-2013, 05:51 PM   #2
Redconvertible
Junior Member
 
Join Date: May 2013
Age: 35
Posts: 3
Default
I had the battery checked and it was good with 100% charge, I'm getting fuel, and spark. The car still won't start. It is turning over but won't start. Any help or advice would be great.
Redconvertible is offline   Reply With Quote
Old 05-11-2013, 10:18 AM   #3
lamthao927697
Junior Member
 
Join Date: May 2013
Age: 27
Posts: 2
Default
- Trung tâm đào tạo và sát hạch lái xe THÀNH CÔNG

- Địa điểm sát hạch của các trung tâm đào tạo lái xe ô tô

- Sát hạch viên trực tiếp giảng dạy

- Học và thi ngay tại trung tâm - cam kết đầu ra



LH: 093.785.9665 - Minh Tú - pḥng tuyển sinh và đào tạo


lamthao927697 is offline   Reply With Quote
Old 05-11-2013, 11:50 AM   #4
lamthao927697
Junior Member
 
Join Date: May 2013
Age: 27
Posts: 2
Default
- Trung tâm đào tạo và sát hạch lái xe THÀNH CÔNG

- Địa điểm sát hạch của các trung tâm đào tạo lái xe ô tô

- Sát hạch viên trực tiếp giảng dạy

- Học và thi ngay tại trung tâm - cam kết đầu ra



LH: 093.785.9665 - Minh Tú - pḥng tuyển sinh và đào tạo


lamthao927697 is offline   Reply With Quote
Old 12-05-2016, 10:18 AM   #5
marathonboats
Junior Member
 
Join Date: Jan 2016
Location: United States
Age: 31
Posts: 15
Send a message via Yahoo to marathonboats
Default
Originally Posted by Redconvertible View Post
In need of help or ideas. I have an 89 RX7 convertible that I attempted to replace the factory radio in. Upon removing the radio from the dash and installing the aftermarket system I noticed the aftermarket system not functioning properly. I put the factory radio back in but now the car won't start. The battery is good and it starts to turn over but won't start. I thought it was flooded but have waited hours with no luck. My factory alarm won't set but if I unlock the car from the drivers side the security light flashes. Also when I remove the key from the ignition the security light flashes. Any help would be appreciated.
I have same problem to solve


__________________
kapal,speedboat,boat,perahu
marathonboats is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump